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Getting Started With Semaphore II

The first thing you should do is create a new message file. This is like any other 
Macintosh document; you create it by running Semaphore II and selecting New 
from the File menu. You will be asked to choose a name and place for the new 
file, using the familiar File dialog. As Semaphore II keeps all of it's messages on 
disk, rather than in memory, it's best if this is on a hard disk, though you can 
copy yours to floppy to carry from machine to machine. Only one file is needed 
for all your messages and replies, just as a Hypercard stack contains many 
cards.
This done, you'll see a window divided into five sections. The three upper 
sections, each with their own scroll bars, show (from left to right) the conference
list, the topic list for the currently selected conference, and the message list in 
the selected topic. Below these is the status bar, which tells you about the 
selected message, and below that is where the message text appears. If you're 
following these instructions live, you haven't any messages yet, so, these look a
bit empty, but things liven up later.
If you look at the right hand edge of the status bar, you'll see an icon with two 



vertically opposed arrows and a dotted line. Dragging this lets you change the 
split between the list area and the message text; if you want you can hide the 
lists entirely.
At the right edge of the screen, you'll see a small palette: this is called the 
"navigator", and you'll see how to use it later to move around your message file.
Anyway, the next step is to get some messages from CIX, and read them, 
otherwise known as "receiving messages."

Receiving Messages

Getting your messages from CIX:
1) log in
2) select compact headers (opt compact y q)
3) type 'file read all' at the main prompt
4) once the dots no longer zoom past (ho ho), type 'down'
5) log out.
If you have done all this properly, you will have a text file on your Mac, with a 
name of 'Scratchpad'. Next, you will need to get Semaphore II to receive the 
messages held in that scratchpad.
Notice that the 'compactheaders' stuff, and most of the other commands, can be
inserted in your CIX profile, or embedded in a terminal emulator script. They're 
not, at the moment - but hey, this is a beta-test, right? (Not anymore, but they’re 
still not done yet...)

Receiving messages into your message file
Double click on your message file to open it, and then choose Receive from the
File menu. You'll get a file dialog asking you to find the scratchpad file you've 
just downloaded (NB: remember to un-arc it first if you've issued an 
ARCSCRATCH while on line - though we'd suggest you don't use 
ARCSCRATCH inthe first place, Mac de-ARCers being what they are!)
A progress dialog will appear while receiving the scratchpad. If you're getting 
bored watching, you can start to read messages while others are being 
received. Having said that, even on an SE, receiving is speedy. If you get 
confused and receive the same scratchpad twice, don't worry - you won't be 
confusing Semaphore at all, it will just ignore the new copies of stuff it already 
has.

Reading Messages

To read your messages, hit splodge-return, or click on the top left tool in the icon
palette.



Moving to another conference or topic out of alpha order is easy: just select the 
conference from the conference list, by clicking, and the topic from the topic list, 
and you'll be taken to the first unread message in the topic (or the last one if 
you've read them all.).

command-return Find next unread
option-command-returnSkip topic and find next unread
command-up See original
command-down See first reply
command-left See previous reply
command-right See next reply
option-command-up Previous message (time order)  
option-command-down Next message (time order)

Replying

OK, so someone has got up your nose and you want to flame them... how do 
you do it?
Start typing. Simple as that; Semaphore II takes care of the rest.
You don't have to be so bold; there's menus, icons in the tool palette, and key 
shortcuts for the business of getting to the editor, too.
Next to the Navigation menu you'll see a Message menu. The first two items 
are Reply and Say. Choosing either of these will make the "Replies" window 
appear. This is where you create and edit replies. You'll see that the layout is 
pretty similar to the message window, and you can get at previous replies by 
selecting them from the list. When this window is active, the Message menu 
changes to a Reply menu.

Sending your Replies
You've read all of your new messages, and replied to a few, and now you want 
to send your replies back to CIX so others can marvel at your wit (or not).
The Send command on the File menu creates a “reply script”, which you  
upload to CIX and execute there. Don't, as one garrulous, tall CIX freelance 
alpha tester did, use the 'send a text file as if it was typed in' feature found in 
many terminal emulators!
First, save your reply script using Send, which will prompt you for a name and 
folder. You can then dial CIX with your comms package, and when online type 
"up, scput script, script". Tell your comms package to upload the file you've just 
saved, and CIX will take care of the rest.
If you look at the reply list after you've sent your replies, you'll see that all of 
your replies are still there, but are all marked with a diamond (also indicated by 
the arrowed phone handset icon in the status bar.) This indicates that the reply 



has been sent.Use Mark Unsent in the Reply menu if you wish to edit and/or 
re-send the reply.

Finding Text

You can search the message file for a piece of text using the Find and Find 
Again commands, in the Edit menu. The Find command presents a dialog 
which asks you for the text, and lets you set the scope of the search. This can 
be limited to the current message, the current topic, the conference or all 
conferences. You can also choose whether the search is case sensitive.
When a topic is being searched, it is searched in reverse order, so the most 
recent occurrence of the text will be found first.

Managing your messages

Getting rid of older messages
After you've been using Semaphore II for a few days, you message file will be 
getting quite large (depending on how many conferences you're in) and you've 
probably got better uses for the disk space.
Semaphore II allows you to "Expire" old messages, so that every message over 
a certain age gets thrown away, releasing space within the message file for new
messages. You can do this manually, by choosing Expire from the File menu 
and telling it how many days of messages you wish to retain.
Alternatively, you can get Semaphore II to automatically expire all messages 
over a given age. You set this age limit in the Expiry Options dialog, in the File
menu. Semaphore II will remove old messages at the end of a "Receive", but 
only once every 24 hours.
Expiring old messages is about the slowest thing Semaphore II does. However, 
while it progresses, you can still read your messages as usual.

Marking, Deleting, Locking & Transferring
Semaphore II gives you many facilities for managing your message files. It 
allows you to delete groups of messages, move messages between message 
file and lock messages so that they cannot be deleted or expired. 

All of these management facilities allow you to perform operations on all  of the 
messages in a topic, conference or whole message base. In  addition, they 
allow you to perform the operation on a set of messages  which have been 
"marked." 



Marking Messages
You can mark a message, all of the messages in a topic, conference or the  
whole message base by using the Mark submenu on the Message menu.  
Similarly, you can use the Unmark submenu to clear the set marks.  
Command-M toggles the mark on and off on a single message.

Locking Messages
Messages which are "locked" cannot be deleted or expired, so you can use  this
to preserve messages which you would like to keep for longer than  usual. Use 
the Lock submenu to lock groups of messages, and the Unlock  submenu to 
clear locks on messages. command-L will toggle the lock on a  single 
message.

Deleting Messages
As well as deleting single messages, you can now delete whole groups of  
messages. Use the Delete submenu to do this. command-Delete deletes  
single messages.

Transferring Messages
The Transfer command, on the file menu, allows you to copy messages  
between message files. On selecting this, you will be shown a modified  file 
dialog. This has a pop-up menu at the bottom of the dialog, which  you can use 
to select what is to be transferred. You can then select  another Semaphore 
message file to transfer the messages to. Flags on  messages such as locks 
and marks will be copied to the new file, and if a message is unread in the 
current file, it will also be marked as unread in the destination file.

Keeping things tidy...
On the File menu, you’ll find an entry marked Tidy. Semaphore II always keeps 
your message files looking neat and tidy on the surface, but underneath that, 
they can sometimes get a bit scruffy. When this happens, you’ll notice 
Semaphore being maybe just a little slower than usual, or your message file 
taking up more space than it should. The Tidy command will sort this out for 
you. If you select it, and then answer the “Do you really want to do this” prompt 
with “yes”, then Semaphore II will go through your messages, getting rid of dead
wood, like empty topics, and packing your messages more tightly together in the
file. This takes a few minutes, but you shouldn’t need to do it very 
often.Other Stuff



Doing a "Say" in a topic not in the message file
Switch to the reply window, and in the Reply menu select the Create New 
Reply submenu. Choose Reply. You'll get the standard 'reply info' dialog into 
which you should type the desired conference and topic, and also a message to
comment to if required.

"Custom" replies
The other option on the Create New Reply submenu is Custom. This allows 
you to add more or less any commands you like into the reply script, so you can
send mail and download files & resumes amongst other things. You can choose 
whether to make the script join a conference before the commands are 
executed, and you can choose to download a named scratchpad afterwards. 
This is for those thoroughly familiar with the CIX script parser!

Changing reply details
If you want, for instance, to change the topic you've done a Say in, you can 
change it by using Get Info, which will allow you to edit the reply details by way
of the dialog mentioned on the previous card. This works for custom replies too.

Deleting individual replies or messages
You can get rid of individual messages or replies using Delete Message and 
Delete Reply, depending on which window is active. Both of these use the 
keyboard shortcut command-delete.

Recovering from corrupt message files
The Transfer facility can be used to recover messages from a corrupted  
message file, in the unlikely event that this happens. If you find a particular 
conference to be corrupted, you  can transfer the other conferences one at a 
time to a new message file  using the Transfer command and selecting 
conference. Transfer Everything  or All Marked may not work work 
predictably if any part of the message  file is corrupt, so using Transfer 
Conference/Topic/Message is  recommended.

New features in version 1.1
Personal Mail

Semaphore can now work with your personal mail messages, reading mail sent 
to you by other CIX users, and sending replies. 

CIX offers a facility to read all your unread mail messages into a scratchpad file 



in much the same way as you would collect your regular conferences. To use 
this facility, you should get to the CIX Mail prompt by typing “Mail” at the “Main” 
prompt. You can then collect the unread messages by typing “file all”. You can 
then quit from the mail system and go on to collect your conferences in the 
usual way, and download both the mail and the conferences in one go.

Once you’ve downloaded your mail & conference messages, they can be read 
into a Semaphore message file using the Receive… command. Semaphore will
put your mail messages into a special conference called “•Personal Mail”, which
has just one topic - “All”. The mail messages can then be read just like they 
were any other kind of message. Replying to mail messages works just the 
same as it does for conference messages too - just start typing and Semaphore 
will create a new reply. Alternatively, you can use the Say or Reply commands, 
or the equivalent icons in the Navigator palette.

Improvements to scratchpad file handling

Semaphore can now read both “verbose” and “terse” message headers, as well 
as the “compact” version. Also, Semaphore can deal with any combination of 
line delimiters in a file - so you no longer need worry about carriage-returns and 
line-feeds. All of these features work automatically - you just use the Receive…
command and Semaphore will do the right thing.

Support for BIX users

BIX is a U.S. based system that uses a version of CoSy - the software used by 
CIX. However, BIX lacks some of the features that make life easier for off-line 
reader users. In particular, BIX lacks any kind of “Reply Script” facility.

Semaphore can read messages downloaded from BIX just like it does CIX 
messages - BIX does not support “compact” message headers, but now that 
Semaphore recognises all of the CoSy message formats, this does not present 
a problem. However, when you send your replies back to BIX, the only way to 
send them is to use something like ZTerm’s “Send Text” command - to send the 
reply file to BIX as if you had typed it in yourself. Semaphore can generate 
replies that will work if uploaded in this way - and you can ask for this to happen
by selecting “Generate BIX-style replies” in the Preferences… dialog. A word of
warning: as you might guess, this way of uploading messages is not as reliable 
as it might be - in particular, if your modem cable is not wired up so that it 
supports “hardware handshaking”, characters will be lost as replies are being 
uploaded, and the results will be unpredictable, to say the least.


